summaryrefslogtreecommitdiff
path: root/puppet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'puppet/Makefile')
-rw-r--r--puppet/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/puppet/Makefile b/puppet/Makefile
index 2209271..97c4a58 100644
--- a/puppet/Makefile
+++ b/puppet/Makefile
@@ -7,7 +7,7 @@
#
# This Makefile is distributed in the hope that it will be useful, but WITHOUT
# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-# # FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License along with
# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
@@ -15,7 +15,7 @@
#
CWD = $(shell pwd)
-REPO = git://git.sarava.org/puppet-bootstrap.git
+REPO = git://git.fluxo.info/puppet-bootstrap.git
PUPPET = FACTER_BOOTSTRAP_PATH="$(CWD)" puppet apply --confdir="$(CWD)" --modulepath=modules
all: deps remote modules config
@@ -57,3 +57,11 @@ clean:
rm -rf ssl
rm -rf modules
git checkout modules
+
+post_update:
+ git config receive.denyCurrentBranch ignore
+ cd .git/hooks && ln -sf ../../bin/post-update
+
+post_receive:
+ git config receive.denyCurrentBranch ignore
+ cd .git/hooks && ln -sf ../../bin/post-receive