summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile2
-rw-r--r--docs/maintenance/README.md6
-rw-r--r--mkdocs.yml56
4 files changed, 64 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 3093b79..29cf613 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,4 @@ build-area
puppet/modules
keyring
site
+.cache
diff --git a/Makefile b/Makefile
index 9496741..c7b1cf4 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,8 @@ web:
web_deploy:
@rsync -avz --delete --exclude=keyring site/ debian:/var/sites/debian/www/
+docs: web
+
publish: web web_deploy
keyring:
diff --git a/docs/maintenance/README.md b/docs/maintenance/README.md
index 22f7956..d454c85 100644
--- a/docs/maintenance/README.md
+++ b/docs/maintenance/README.md
@@ -1 +1,7 @@
# Debian maintenance
+
+## Tracking downtimes
+
+* [/downtimed/](https://dist.epipe.com/downtimed/)
+ * [downtimed - Debian Package Tracker](https://tracker.debian.org/pkg/downtimed)
+ * [Debian -- Details of package downtimed in bookworm](https://packages.debian.org/bookworm/downtimed)
diff --git a/mkdocs.yml b/mkdocs.yml
index cbd5381..4b5a5bf 100644
--- a/mkdocs.yml
+++ b/mkdocs.yml
@@ -17,7 +17,61 @@ theme:
#
# This option was superseded by the privacy plugin:
# https://squidfunk.github.io/mkdocs-material/setup/ensuring-data-privacy/#built-in-privacy-plugin
- font: false
+ #font: false
+
+# Plugins
+# https://www.mkdocs.org/dev-guide/plugins/
+plugins:
+ # Note that this might not be available in the mkdocs-material package from
+ # Debian bookworm (as of 2024-08-23)
+ privacy: {}
+
+# Markdown extensions
+# See https://www.mkdocs.org/user-guide/configuration/#markdown_extensions
+# https://squidfunk.github.io/mkdocs-material/setup/extensions/
+markdown_extensions:
+ # Footnotes
+ # https://squidfunk.github.io/mkdocs-material/reference/footnotes/
+ footnotes: {}
+
+ # Tasklist handling
+ # https://squidfunk.github.io/mkdocs-material/setup/extensions/python-markdown-extensions/#tasklist
+ pymdownx.tasklist:
+ custom_checkbox: true
+
+ # SuperFences
+ # https://squidfunk.github.io/mkdocs-material/setup/extensions/python-markdown-extensions/#superfences
+ pymdownx.superfences:
+ custom_fences:
+ - name: mermaid
+ class: mermaid
+ format: !!python/name:pymdownx.superfences.fence_code_format
+
+ # Table of Contents configuration
+ # See https://www.mkdocs.org/user-guide/configuration/#markdown_extensions
+ # https://www.mkdocs.org/user-guide/writing-your-docs/#linking-to-pages
+ toc:
+ permalink: true
+
+ # Attribute Lists
+ # Needed by proper image handling
+ # https://squidfunk.github.io/mkdocs-material/reference/images/
+ # https://squidfunk.github.io/mkdocs-material/setup/extensions/python-markdown/#attribute-lists
+ attr_list: {}
+
+ # Markdown in HTML
+ # Needed by proper image handling
+ # https://squidfunk.github.io/mkdocs-material/reference/images/
+ # https://squidfunk.github.io/mkdocs-material/setup/extensions/python-markdown/#markdown-in-html
+ md_in_html: {}
+
+# Copyright notice
+copyright: Copyleft © 2024 Fluxo Group. See LICENSE for details.
+
+# Extra template parameters
+# https://www.mkdocs.org/user-guide/configuration/#extra
+extra:
+ generator: false
# Navigation
# https://www.mkdocs.org/user-guide/writing-your-docs/#configure-pages-and-navigation