summaryrefslogtreecommitdiff
path: root/python.md
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2022-04-19 10:43:08 -0300
committerSilvio Rhatto <rhatto@riseup.net>2022-04-19 10:43:08 -0300
commitf2cbc3890e6a6a527cdaaf19ab81341306179a9d (patch)
tree3e7d3623ad1d8898d79f6eefdc0050489aedfd49 /python.md
parente1ae213fffc411d04f5674744259c4c2630686b2 (diff)
downloaddebian-f2cbc3890e6a6a527cdaaf19ab81341306179a9d.tar.gz
debian-f2cbc3890e6a6a527cdaaf19ab81341306179a9d.tar.bz2
Additional references
Diffstat (limited to 'python.md')
-rw-r--r--python.md22
1 files changed, 22 insertions, 0 deletions
diff --git a/python.md b/python.md
index fd751d0..ada80f0 100644
--- a/python.md
+++ b/python.md
@@ -1,5 +1,7 @@
[[!meta title="Python packaging"]]
+## Old procedure
+
Example: using [stdeb](http://github.com/astraw/stdeb) to build [http://kedpm.sf.net].
sudo apt-get install stdeb fakeroot
@@ -28,3 +30,23 @@ Packaging:
dpkg-buildpackage -rfakeroot -uc -us
cd ..
sudo dpkg -i kedpm_0.4.0-1_all.deb
+
+## References
+
+* [Python/Pybuild - Debian Wiki](https://wiki.debian.org/Python/Pybuild "Python/Pybuild - Debian Wiki")
+ * [Packaging Python Applications for Debian | Snakes on Callisto](https://jhermann.github.io/blog/python/devops/2020/03/28/dh_virtualenv_howto.html "Packaging Python Applications for Debian | Snakes on Callisto")
+ * [Debian -- Details of package python3-stdeb in bullseye](https://packages.debian.org/bullseye/python3-stdeb "Debian -- Details of package python3-stdeb in bullseye")
+ * [Creating configuration files in /etc in Debian packages - pi3g.com](https://pi3g.com/2020/04/05/creating-configuration-files-in-etc-in-debian-packages/ "Creating configuration files in /etc in Debian packages - pi3g.com")
+ * [PbuilderHowto - Ubuntu Wiki](https://wiki.ubuntu.com/PbuilderHowto "PbuilderHowto - Ubuntu Wiki")
+ * [PyBuilder — Tutorial](https://pybuilder.io/documentation/tutorial "PyBuilder — Tutorial")
+ * [Distributing Python Modules (Legacy version) — Python 3.10.4 documentation](https://docs.python.org/3/distutils/index.html "Distributing Python Modules (Legacy version) — Python 3.10.4 documentation")
+ * [Distributing Python Modules — Python 3.10.4 documentation](https://docs.python.org/3/distributing/index.html#distributing-index "Distributing Python Modules — Python 3.10.4 documentation")
+ * [What’s New In Python 3.10 — Python 3.10.4 documentation](https://docs.python.org/3/whatsnew/3.10.html#distutils-deprecated "What’s New In Python 3.10 — Python 3.10.4 documentation")
+ * [PEP 632 – Deprecate distutils module | peps.python.org](https://peps.python.org/pep-0632/ "PEP 632 – Deprecate distutils module | peps.python.org")
+ * [python - setup.py build doesn't work but develop does - Stack Overflow](https://stackoverflow.com/questions/38729475/setup-py-build-doesnt-work-but-develop-does "python - setup.py build doesn't work but develop does - Stack Overflow")
+ * [pybuild(1) — dh-python — Debian testing — Debian Manpages](https://manpages.debian.org/testing/dh-python/pybuild.1.en.html "pybuild(1) — dh-python — Debian testing — Debian Manpages")
+ * [Debian -- Details of package dh-python in bullseye-backports](https://packages.debian.org/bullseye-backports/dh-python "Debian -- Details of package dh-python in bullseye-backports")
+ * [#1001459 - dh-python: SetuptoolsDeprecationWarning: setup.py install is deprecated - Debian Bug report logs](https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1001459 "#1001459 - dh-python: SetuptoolsDeprecationWarning: setup.py install is deprecated - Debian Bug report logs")
+ * [Bugs in package dh-python (version 5.20220403) in unstable -- Debian Bug report logs](https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=dh-python;dist=unstable "Bugs in package dh-python (version 5.20220403) in unstable -- Debian Bug report logs")
+ * [Debian Python Policy — Debian Python Documentation Project 1.0 documentation](https://debian-python.readthedocs.io/en/latest/debian-policy.html "Debian Python Policy — Debian Python Documentation Project 1.0 documentation")
+ * [dh-python/plugin_distutils.py at master · p1otr/dh-python](https://github.com/p1otr/dh-python/blob/master/dhpython/build/plugin_distutils.py "dh-python/plugin_distutils.py at master · p1otr/dh-python")