summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2014-10-17 18:41:48 -0300
committerSilvio Rhatto <rhatto@riseup.net>2014-10-17 18:41:48 -0300
commitac5e31e4a3bee6d503f9ab5f9470228a7c0c61a2 (patch)
tree820b8399f5d59f36b33a993e47f1c77374194165
parent8712f70feb7879654db47446756915b2ba6bd26f (diff)
downloaddebian-ac5e31e4a3bee6d503f9ab5f9470228a7c0c61a2.tar.gz
debian-ac5e31e4a3bee6d503f9ab5f9470228a7c0c61a2.tar.bz2
On ruby/leap_cli packaging
-rw-r--r--TODO.md2
-rw-r--r--ruby.md18
2 files changed, 19 insertions, 1 deletions
diff --git a/TODO.md b/TODO.md
index b57df04..29421e0 100644
--- a/TODO.md
+++ b/TODO.md
@@ -30,7 +30,7 @@ Port
----
* pond.
-* leap-cli (check http://deb.leap.se).
+* [leap-cli](https://leap.se) (check http://deb.leap.se).
* [Blingbling](http://awesome.naquadah.org/wiki/Blingbling).
* [x2go-server](https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=465821).
* [Terminology](https://www.enlightenment.org/p.php?p=about/terminology).
diff --git a/ruby.md b/ruby.md
index 541532b..3ad574d 100644
--- a/ruby.md
+++ b/ruby.md
@@ -2,3 +2,21 @@ Ruby packaging
==============
See [this](https://wiki.debian.org/Teams/Ruby/Packaging).
+
+Example: packaging leap_cli and dependencies
+--------------------------------------------
+
+First, in a *fresh* vagrant box:
+
+ sudo gem install leap_cli
+
+Then we get the dependencies and build all packages:
+
+ gem list | cut -d '(' -f 1 | while read gem; do gem2deb $gem; done
+
+Additional steps:
+
+* Fix `debian/control` and other FIXME's on each package.
+* Put `debian/` folder in a `debian` branch on each source.
+* [Review the code](https://manual.sarava.org/specs/code/).
+* Upstream pull requests.