aboutsummaryrefslogtreecommitdiff
path: root/development.mdwn
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2013-12-15 13:27:56 -0200
committerSilvio Rhatto <rhatto@riseup.net>2013-12-15 13:27:56 -0200
commit457c714dfa4a533074e51f91e90aea6b5cac78f9 (patch)
tree4d0b91a12b4fd47437da1ee96376e5929d12f93f /development.mdwn
parentb4bdeafcf666b6f7a6f3f33e9f4cf1fb0a7cebbf (diff)
downloadkeyringer-457c714dfa4a533074e51f91e90aea6b5cac78f9.tar.gz
keyringer-457c714dfa4a533074e51f91e90aea6b5cac78f9.tar.bz2
Simplifying debian branch tagging
Diffstat (limited to 'development.mdwn')
-rw-r--r--development.mdwn6
1 files changed, 1 insertions, 5 deletions
diff --git a/development.mdwn b/development.mdwn
index 8366b59..cf969fe 100644
--- a/development.mdwn
+++ b/development.mdwn
@@ -60,7 +60,7 @@ Update the debian branch:
git-import-orig --upstream-vcs-tag=$VERSION ../tarballs/keyringer-$VERSION.tar.bz2
dch -e # fine tune the changelog prepared by git-dch
git commit -a -m "Updating debian/changelog"
- git tag -s debian_keyringer_$VERSION-1 -m "Keyringer debian package $VERSION-1"
+ git-buildpackage --git-tag-only --git-sign-tags
Push everything:
@@ -75,10 +75,6 @@ Run lintian (or [add it to your pbuilder hooks](http://askubuntu.com/questions/1
lintian --info --display-info --pedantic --color auto \
../build-area/keyringer_$VERSION*.changes
-Create a signed tag in the debian branch:
-
- git-buildpackage --git-tag-only --git-sign-tags
-
Notes:
* `git-import-orig` takes care of running `pristine-tar commit`, of merging of the tag and orig tarball into the upstream branch, and then it merges the result into the debian branch. With the above configuration, it also runs git-dch to do the bulk of the work in `debian/changelog`.