summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2016-11-09 10:27:57 -0200
committerSilvio Rhatto <rhatto@riseup.net>2016-11-09 10:27:57 -0200
commite19c2219a9a4b1962151cd886ef025826e2838c7 (patch)
tree53c4eaba89b3b564a778f4ec299b6fb19e48bf3d /Makefile
parent84319a2c2806f623adbff33a804a3338905ebd3e (diff)
parent321be0df19d4443a4f13ca9870782f7c4ece049f (diff)
downloadkeyringer-e19c2219a9a4b1962151cd886ef025826e2838c7.tar.gz
keyringer-e19c2219a9a4b1962151cd886ef025826e2838c7.tar.bz2
Merge tag 'upstream_keyringer_0.4.0' into debian
Upstream version 0.4.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 07513f2..b503b68 100644
--- a/Makefile
+++ b/Makefile
@@ -34,7 +34,7 @@ install_bin:
$(INSTALL) -D --mode=0755 keyringer $(DESTDIR)/$(PREFIX)/bin/keyringer
install_doc:
- $(INSTALL) -D --mode=0644 index.mdwn $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE)/README
+ $(INSTALL) -D --mode=0644 index.mdwn $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE)/README.md
$(INSTALL) -D --mode=0644 LICENSE $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE)/LICENSE
install_man:
@@ -64,8 +64,9 @@ release:
# https://github.com/nvie/gitflow/pull/160
# https://github.com/nvie/gitflow/issues/50
#git flow release finish -s -m "Keyringer $(VERSION)" $(VERSION)
- git flow release finish -s $(VERSION)
+ #git flow release finish -s $(VERSION)
git checkout master
+ git merge develop
@make tarball
gpg --use-agent --armor --detach-sign --output $(ARCHIVE)/keyringer-$(VERSION).tar.bz2.asc $(ARCHIVE)/keyringer-$(VERSION).tar.bz2
scp $(ARCHIVE)/keyringer-$(VERSION).tar.bz2* keyringer:/var/sites/keyringer/releases/
@@ -81,3 +82,11 @@ debian:
dch -e
git commit -a -m "Updating debian/changelog"
git-buildpackage --git-tag-only --git-sign-tags
+
+web:
+ @ikiwiki --setup ikiwiki.setup
+
+web_deploy:
+ @rsync -avz --delete www/ blog:/var/sites/keyringer/www/
+
+publish: web web_deploy