summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2014-05-20 12:06:24 -0300
committerSilvio Rhatto <rhatto@riseup.net>2014-05-20 12:06:24 -0300
commit00c0df3775d715324c4ab28cd39290184fcc71c2 (patch)
treee991c8fdc04066c8a3c36cb151a8a78a4111a517 /Makefile
parent50d334dbeb99301df586cead506c6bd0ec7fb223 (diff)
parentac8cb00ad88736377a8e9458390cc99aba92cb22 (diff)
downloadkeyringer-00c0df3775d715324c4ab28cd39290184fcc71c2.tar.gz
keyringer-00c0df3775d715324c4ab28cd39290184fcc71c2.tar.bz2
Merge tag 'upstream_keyringer_0.3.5' into debian
Upstream version 0.3.5
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 42f6d9b..7ef6001 100644
--- a/Makefile
+++ b/Makefile
@@ -26,6 +26,8 @@ install_lib:
$(INSTALL) -D --mode=0755 lib/keyringer/functions $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/functions
$(INSTALL) -D --mode=0755 -d lib/keyringer/actions $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions
$(INSTALL) -D --mode=0755 lib/keyringer/actions/* $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions
+ $(INSTALL) -D --mode=0755 -d lib/keyringer/editors $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions
+ $(INSTALL) -D --mode=0755 lib/keyringer/editors/* $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions
install_bin:
$(INSTALL) -D --mode=0755 keyringer $(DESTDIR)/$(PREFIX)/bin/keyringer
@@ -56,9 +58,12 @@ tarball:
release:
@make build_man
git commit -a -m "Keyringer $(VERSION)"
+ git flow release finish -s -m "Keyringer $(VERSION)" $(VERSION)
+ git checkout master
@make tarball
gpg --use-agent --armor --detach-sign --output ../tarballs/keyringer-$(VERSION).tar.bz2.asc ../tarballs/keyringer-$(VERSION).tar.bz2
scp ../tarballs/keyringer-$(VERSION).tar.bz2* keyringer:/var/sites/keyringer/releases/
# We're doing tagging afterwards:
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=568375
- git tag -s $(VERSION) -m "Keyringer $(VERSION)"
+ #git tag -s $(VERSION) -m "Keyringer $(VERSION)"
+ git checkout develop