diff options
author | Silvio Rhatto <rhatto@riseup.net> | 2014-05-20 12:29:43 -0300 |
---|---|---|
committer | Silvio Rhatto <rhatto@riseup.net> | 2014-05-20 12:29:43 -0300 |
commit | dd04180ccea3ecbebc567b522ae2a0ea02d30ec2 (patch) | |
tree | b3a0b729c9603c2223b7e33921ef58daec0298d4 /Makefile | |
parent | b6880c29861e1ed826d40d589ba96b4ce46735d3 (diff) | |
download | keyringer-dd04180ccea3ecbebc567b522ae2a0ea02d30ec2.tar.gz keyringer-dd04180ccea3ecbebc567b522ae2a0ea02d30ec2.tar.bz2 |
Makefile fix and updated workflow
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 18 |
1 files changed, 15 insertions, 3 deletions
@@ -26,8 +26,8 @@ install_lib: $(INSTALL) -D --mode=0755 lib/keyringer/functions $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/functions $(INSTALL) -D --mode=0755 -d lib/keyringer/actions $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions $(INSTALL) -D --mode=0755 lib/keyringer/actions/* $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions - $(INSTALL) -D --mode=0755 -d lib/keyringer/editors $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions - $(INSTALL) -D --mode=0755 lib/keyringer/editors/* $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/actions + $(INSTALL) -D --mode=0755 -d lib/keyringer/editors $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/editors + $(INSTALL) -D --mode=0755 lib/keyringer/editors/* $(DESTDIR)/$(PREFIX)/lib/$(PACKAGE)/editors install_bin: $(INSTALL) -D --mode=0755 keyringer $(DESTDIR)/$(PREFIX)/bin/keyringer @@ -58,7 +58,11 @@ tarball: release: @make build_man git commit -a -m "Keyringer $(VERSION)" - git flow release finish -s -m "Keyringer $(VERSION)" $(VERSION) + # See https://github.com/nvie/gitflow/issues/87 + # https://github.com/nvie/gitflow/pull/160 + # https://github.com/nvie/gitflow/issues/50 + #git flow release finish -s -m "Keyringer $(VERSION)" $(VERSION) + git flow release finish -s $(VERSION) git checkout master @make tarball gpg --use-agent --armor --detach-sign --output ../tarballs/keyringer-$(VERSION).tar.bz2.asc ../tarballs/keyringer-$(VERSION).tar.bz2 @@ -67,3 +71,11 @@ release: # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=568375 #git tag -s $(VERSION) -m "Keyringer $(VERSION)" git checkout develop + +debian: + git checkout debian + git-import-orig --upstream-vcs-tag=$(VERSION) ../tarballs/keyringer-$(VERSION).tar.bz2 + # Fine tune debian/changelog prepared by git-dch + dch -e + git commit -a -m "Updating debian/changelog" + git-buildpackage --git-tag-only --git-sign-tags |