summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2013-11-26 17:18:57 -0200
committerSilvio Rhatto <rhatto@riseup.net>2013-11-26 17:18:57 -0200
commitef46233be5016435ada01b36d3d9fe27f1097e3b (patch)
tree25c8edec8ff092348317ac3a038f4941ac7acef4 /Makefile
parentcc7f823348eb24802cd85232cdbcdc8b1ab070e0 (diff)
parent5f1590e0722ee5ee9fed2ccc43adfb88f00218fd (diff)
downloadkeyringer-ef46233be5016435ada01b36d3d9fe27f1097e3b.tar.gz
keyringer-ef46233be5016435ada01b36d3d9fe27f1097e3b.tar.bz2
Merge tag 'upstream_keyringer_0.2.9' into debian
Upstream version 0.2.9
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0d2ef3a..360bd29 100644
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,18 @@ install: clean
@make install_lib install_bin install_doc install_man install_completion
build_man:
+ # Pipe output to sed to avoid http://lintian.debian.org/tags/hyphen-used-as-minus-sign.html
+ # Fixed in http://johnmacfarlane.net/pandoc/releases.html#pandoc-1.10-2013-01-19
pandoc -s -w man share/man/keyringer.1.mdwn -o share/man/keyringer.1
+ sed -i -e 's/--/\\-\\-/g' share/man/keyringer.1
tarball:
git archive --prefix=keyringer-$(VERSION)/ --format=tar HEAD | bzip2 >../tarballs/keyringer-$(VERSION).tar.bz2
+
+release:
+ @make build_man
+ git commit -a -m "Keyringer $(VERSION)"
+ git tag -s $(VERSION) -m "Keyringer $(VERSION)"
+ @make tarball
+ gpg --armor --detach-sign --output ../tarballs/keyringer-$(VERSION).tar.bz2.asc ../tarballs/keyringer-$(VERSION).tar.bz2
+ scp ../tarballs/keyringer-$(VERSION).tar.bz2* keyringer:/var/sites/keyringer/releases/