aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2020-01-18 11:19:11 -0300
committerSilvio Rhatto <rhatto@riseup.net>2020-01-18 11:19:11 -0300
commit36f28df76c0ac0e8706fb00ec51820aa1df07c2f (patch)
tree9ef21722e639dfffaf9d2d5d37d4feaec098b6d0
parentf4d296e14cf5d150064c10a8342bbac75b7e994e (diff)
downloadkeyringer-36f28df76c0ac0e8706fb00ec51820aa1df07c2f.tar.gz
keyringer-36f28df76c0ac0e8706fb00ec51820aa1df07c2f.tar.bz2
Install zsh completion in the default path
Install the zsh completer into site-functions rather than vendor-completions. vendor-completions is a Debian-ism that many distros and other OSes don't support. site-functions is added to the default fpath by zsh, so it should just work for all users. Patch thanks to Matthew Martin.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 53dd921..9946667 100644
--- a/Makefile
+++ b/Makefile
@@ -43,7 +43,7 @@ install_man:
install_completion:
$(INSTALL) -D -m 0644 lib/keyringer/completions/bash/keyringer $(DESTDIR)/$(PREFIX)/share/bash-completion/completions/keyringer
- $(INSTALL) -D -m 0644 lib/keyringer/completions/zsh/_keyringer $(DESTDIR)/$(PREFIX)/share/zsh/vendor-completions/_keyringer
+ $(INSTALL) -D -m 0644 lib/keyringer/completions/zsh/_keyringer $(DESTDIR)/$(PREFIX)/share/zsh/site-functions/_keyringer
install: clean
@make install_lib install_bin install_doc install_man install_completion