summaryrefslogtreecommitdiff
path: root/puppet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'puppet/Makefile')
-rw-r--r--puppet/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/puppet/Makefile b/puppet/Makefile
new file mode 100644
index 0000000..97c4a58
--- /dev/null
+++ b/puppet/Makefile
@@ -0,0 +1,67 @@
+#
+# Puppet Boostrap Makefile by Silvio Rhatto (rhatto at riseup.net).
+#
+# This Makefile is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the Free
+# Software Foundation; either version 3 of the License, or any later version.
+#
+# This Makefile is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
+#
+
+CWD = $(shell pwd)
+REPO = git://git.fluxo.info/puppet-bootstrap.git
+PUPPET = FACTER_BOOTSTRAP_PATH="$(CWD)" puppet apply --confdir="$(CWD)" --modulepath=modules
+
+all: deps remote modules config
+
+deps:
+ bin/dependencies
+
+modules:
+ mr up
+
+submodules:
+ bin/submodules
+
+subtrees:
+ bin/subtrees
+
+symlinks:
+ bin/symlinks $(MODULES)
+
+remote:
+ git remote add bootstrap $(REPO)
+
+hiera/boostrap.yaml:
+ $(EDITOR) hiera/bootstrap.yaml
+
+puppet.conf:
+ mkdir -p $(HOME)/.puppet
+ $(PUPPET) manifests/bootstrap/configurator.pp
+
+config: hiera/boostrap.yaml puppet.conf
+ @true
+
+apply:
+ $(PUPPET) manifests/bootstrap/$(stage).pp
+
+clean:
+ rm -f auth.conf fileserver.conf puppet.conf
+ rm -f manifests/classes/users.pp
+ rm -rf ssl
+ rm -rf modules
+ git checkout modules
+
+post_update:
+ git config receive.denyCurrentBranch ignore
+ cd .git/hooks && ln -sf ../../bin/post-update
+
+post_receive:
+ git config receive.denyCurrentBranch ignore
+ cd .git/hooks && ln -sf ../../bin/post-receive