summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile74
1 files changed, 14 insertions, 60 deletions
diff --git a/Makefile b/Makefile
index 97c4a58..a58550d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,67 +1,21 @@
#
-# Puppet Boostrap Makefile by Silvio Rhatto (rhatto at riseup.net).
+# Ikiwiki Makefile by Silvio Rhatto (rhatto at riseup.net).
#
-# This Makefile is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by the Free
-# Software Foundation; either version 3 of the License, or any later version.
+# This Makefile is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the Free
+# Software Foundation; either version 3 of the License, or any later version.
#
-# This Makefile is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+# This Makefile is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place - Suite 330, Boston, MA 02111-1307, USA
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place - Suite 330, Boston, MA 02111-1307, USA
#
-CWD = $(shell pwd)
-REPO = git://git.fluxo.info/puppet-bootstrap.git
-PUPPET = FACTER_BOOTSTRAP_PATH="$(CWD)" puppet apply --confdir="$(CWD)" --modulepath=modules
+web:
+ @ikiwiki --setup ikiwiki.setup
-all: deps remote modules config
-
-deps:
- bin/dependencies
-
-modules:
- mr up
-
-submodules:
- bin/submodules
-
-subtrees:
- bin/subtrees
-
-symlinks:
- bin/symlinks $(MODULES)
-
-remote:
- git remote add bootstrap $(REPO)
-
-hiera/boostrap.yaml:
- $(EDITOR) hiera/bootstrap.yaml
-
-puppet.conf:
- mkdir -p $(HOME)/.puppet
- $(PUPPET) manifests/bootstrap/configurator.pp
-
-config: hiera/boostrap.yaml puppet.conf
- @true
-
-apply:
- $(PUPPET) manifests/bootstrap/$(stage).pp
-
-clean:
- rm -f auth.conf fileserver.conf puppet.conf
- rm -f manifests/classes/users.pp
- rm -rf ssl
- rm -rf modules
- git checkout modules
-
-post_update:
- git config receive.denyCurrentBranch ignore
- cd .git/hooks && ln -sf ../../bin/post-update
-
-post_receive:
- git config receive.denyCurrentBranch ignore
- cd .git/hooks && ln -sf ../../bin/post-receive
+web_deploy:
+ @rsync -avz --delete --exclude=keyring www/ debian:/var/sites/debian/www/