summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2015-11-06 10:59:50 -0200
committerSilvio Rhatto <rhatto@riseup.net>2015-11-06 10:59:50 -0200
commit506b62a99e35c69354e8bc977780e41117f1e6ca (patch)
tree6c0964811d5972c2dcb15d252d689c999ae70f5a
parent4e6da46af5e647edbeb4a0afd6a5f5fb070476a7 (diff)
downloaddebian-506b62a99e35c69354e8bc977780e41117f1e6ca.tar.gz
debian-506b62a99e35c69354e8bc977780e41117f1e6ca.tar.bz2
Static website config
-rw-r--r--Makefile2
-rw-r--r--TODO.md5
-rw-r--r--ikiwiki.setup14
-rw-r--r--index.mdwn10
-rw-r--r--templates/page.tmpl2
5 files changed, 17 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index 3e5d279..a58550d 100644
--- a/Makefile
+++ b/Makefile
@@ -18,4 +18,4 @@ web:
@ikiwiki --setup ikiwiki.setup
web_deploy:
- @rsync -avz --delete www/ debian:/var/sites/debian/www/
+ @rsync -avz --delete --exclude=keyring www/ debian:/var/sites/debian/www/
diff --git a/TODO.md b/TODO.md
index eddf73b..dae1f7b 100644
--- a/TODO.md
+++ b/TODO.md
@@ -9,7 +9,7 @@ Organization
* `debian-dev-setup`.
* `debian-build`.
* Merge all `build-area` folders.
-* Deploy as a ikiwiki + git-annex instance, perhaps replacing reprepro.
+* Deploy as a ikiwiki + git-annex instance, replacing reprepro.
* Try an [AutomateBackports](https://wiki.debian.org/AutomateBackports) setup.
* Vagrant: run `debian-dev-setup` as an additional shell provisioner.
* Security: https://wiki.debian.org/SecurePbuilder
@@ -27,6 +27,7 @@ Backport
* http://dev.mutt.org/hg/mutt/rev/b38c4838976f and other patches
* https://www.8t8.us/mutt/patches/
* [#757117 - mutt-patched: Please add patch to encrypt postponed messages - Debian Bug report logs](https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=757117).
+* [firejail](https://l3net.wordpress.com/projects/firejail/) [from sid](https://packages.debian.org/sid/firejail).
Port
----
@@ -37,6 +38,8 @@ Port
* [Blingbling](http://awesome.naquadah.org/wiki/Blingbling).
* [x2go-server](https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=465821).
* [Terminology](https://www.enlightenment.org/p.php?p=about/terminology).
+* [playpen](https://github.com/thestinger/playpen).
+* [minijail](https://github.com/omegaup/minijail).
WNPP
----
diff --git a/ikiwiki.setup b/ikiwiki.setup
index a478960..210577d 100644
--- a/ikiwiki.setup
+++ b/ikiwiki.setup
@@ -8,28 +8,28 @@
use IkiWiki::Setup::Standard {
wikiname => "Debian Packages",
admindebian => ["debian", ],
- adminemail => 'debian@sarava.org',
+ adminemail => 'debian@fluxo.info',
# Be sure to customise these..
srcdir => ".",
destdir => "www",
- url => "https://debian.sarava.org",
- cgiurl => "https://debian.sarava.org/ikiwiki.cgi",
+ url => "https://debian.fluxo.info",
+ cgiurl => "https://debian.fluxo.info/ikiwiki.cgi",
#templatedir => "/usr/share/ikiwiki/templates",
#underlaydir => "/usr/share/ikiwiki/basewiki",
# Subversion stuff.
#rcs => "svn",
- #historyurl => "http://svn.sarava.org/trunk/[[file]]",
- #diffurl => "http://svn.sarava.org/trunk/[[file]]?root=wiki&amp;r1=[[r1]]&amp;r2=[[r2]]",
+ #historyurl => "http://svn.fluxo.info/trunk/[[file]]",
+ #diffurl => "http://svn.fluxo.info/trunk/[[file]]?root=wiki&amp;r1=[[r1]]&amp;r2=[[r2]]",
#svnrepo => "/svn/wiki",
#svnpath => "trunk",
# Git stuff.
rcs => "git",
- historyurl => "https://git.sarava.org/?p=debian.git;a=history;f=[[file]]",
- diffurl => "https://git.sarava.org/?p=debian.git;a=blobdiff;h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_parent]];f=[[file]]",
+ historyurl => "https://git.fluxo.info/?p=debian.git;a=history;f=[[file]]",
+ diffurl => "https://git.fluxo.info/?p=debian.git;a=blobdiff;h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_parent]];f=[[file]]",
#gitorigin_branch => "origin",
#gitmaster_branch => "master",
# See https://ikiwiki.info/tips/laptop_wiki_with_git/
diff --git a/index.mdwn b/index.mdwn
index f6c7e6d..86f10fa 100644
--- a/index.mdwn
+++ b/index.mdwn
@@ -1,7 +1,6 @@
-Debian packaging effort!
-========================
+[[!meta title="Debian packaging effort!"]]
-In the past, we used to be [heavy slackware users](https://simplepkg.sarava.org) when we just
+In the past, we used to be [heavy slackware users](https://simplepkg.fluxo.info) when we just
had a few boxes to manage. Then we had to change our whole packaging paradigm when we switched
to Debian.
@@ -10,13 +9,12 @@ the course of learning the intricacies of Debian packaging.
Grab this repository using
- git clone --recursive git://git.sarava.org/debian.git
+ git clone --recursive git://git.fluxo.info/debian.git
Configuration files
-------------------
-All the commands in this guide assumes that you're using [these configuration
-files](https://git.sarava.org/?p=rhatto/dotfiles/debian.git;a=summary).
+All the commands in this guide assumes that you're using [these configuration files](https://git.fluxo.info/?p=rhatto/dotfiles/debian.git;a=summary).
Starting a new package
----------------------
diff --git a/templates/page.tmpl b/templates/page.tmpl
index 2e18cdc..b525d22 100644
--- a/templates/page.tmpl
+++ b/templates/page.tmpl
@@ -16,7 +16,7 @@
<link rel="icon" href="<TMPL_VAR BASEURL><TMPL_VAR FAVICON>" type="image/x-icon" />
</TMPL_IF>
<link rel="stylesheet" href="<TMPL_VAR BASEURL>bootstrap/css/bootstrap.min.css" type="text/css" />
-<link rel="stylesheet" href="<TMPL_VAR BASEURL>bootstrap/css/bootstrap-responsive.css" />
+<link rel="stylesheet" href="<TMPL_VAR BASEURL>bootstrap/css/bootstrap-responsive.min.css" />
<TMPL_IF LOCAL_CSS>
<link rel="stylesheet" href="<TMPL_VAR BASEURL><TMPL_VAR LOCAL_CSS>" type="text/css" />
<TMPL_ELSE>