aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSilvio Rhatto <rhatto@riseup.net>2016-07-03 12:04:05 -0300
committerSilvio Rhatto <rhatto@riseup.net>2016-07-03 12:04:05 -0300
commit9c307fcdaab2e34d3f5d30346c9a6cec07f955bb (patch)
tree25c30127c5039bbd7ddef8adb6bae8bd81058f05
parentce9fe1ed9ba8b567fd5150f03a4b3bb8e7e1d9ca (diff)
downloadbootless-9c307fcdaab2e34d3f5d30346c9a6cec07f955bb.tar.gz
bootless-9c307fcdaab2e34d3f5d30346c9a6cec07f955bb.tar.bz2
Makefile: packaging support
-rw-r--r--Makefile63
1 files changed, 62 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 504baf7..2622a33 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
#
-# Ikiwiki Makefile by Silvio Rhatto (rhatto at riseup.net).
+# Bootless Makefile by Silvio Rhatto (rhatto at riseup.net).
#
# This Makefile is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by the Free
@@ -14,6 +14,67 @@
# Place - Suite 330, Boston, MA 02111-1307, USA
#
+PACKAGE = bootless
+VERSION = $(shell ./bootless | head -n 1 | cut -d ' ' -f 2)
+PREFIX ?= /usr/local
+ARCHIVE ?= tarballs
+INSTALL = /usr/bin/install
+
+clean:
+ find . -name *~ | xargs rm -f # clean local backups
+
+install_bin:
+ $(INSTALL) -D --mode=0755 bootless $(DESTDIR)/$(PREFIX)/bin/bootless
+
+install_doc:
+ $(INSTALL) -D --mode=0644 index.mdwn $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE)/README.md
+ $(INSTALL) -D --mode=0644 LICENSE $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE)/LICENSE
+
+#install_man:
+# $(INSTALL) -D --mode=0644 share/man/bootless.1 $(DESTDIR)/$(PREFIX)/share/man/man1/bootless.1
+
+#install_completion:
+# $(INSTALL) -D --mode=0644 lib/bootless/completions/bash/bootless $(DESTDIR)/$(PREFIX)/share/bash-completion/completions/bootless
+# $(INSTALL) -D --mode=0644 lib/bootless/completions/zsh/_bootless $(DESTDIR)/$(PREFIX)/share/zsh/vendor-completions/_bootless
+
+install: clean
+ @make install_lib install_bin install_doc# install_man install_completion
+
+build_man:
+ # Pipe output to sed to avoid http://lintian.debian.org/tags/hyphen-used-as-minus-sign.html
+ # Fixed in http://johnmacfarlane.net/pandoc/releases.html#pandoc-1.10-2013-01-19
+ pandoc -s -w man share/man/bootless.1.mdwn -o share/man/bootless.1
+ sed -i -e 's/--/\\-\\-/g' share/man/bootless.1
+
+tarball:
+ mkdir -p $(ARCHIVE)
+ git archive --prefix=bootless-$(VERSION)/ --format=tar HEAD | bzip2 > $(ARCHIVE)/bootless-$(VERSION).tar.bz2
+
+release:
+ @make build_man
+ git commit -a -m "bootless $(VERSION)"
+ # See https://github.com/nvie/gitflow/issues/87
+ # https://github.com/nvie/gitflow/pull/160
+ # https://github.com/nvie/gitflow/issues/50
+ #git flow release finish -s -m "bootless $(VERSION)" $(VERSION)
+ git flow release finish -s $(VERSION)
+ git checkout master
+ @make tarball
+ gpg --use-agent --armor --detach-sign --output $(ARCHIVE)/bootless-$(VERSION).tar.bz2.asc $(ARCHIVE)/bootless-$(VERSION).tar.bz2
+ scp $(ARCHIVE)/bootless-$(VERSION).tar.bz2* bootless:/var/sites/bootless/releases/
+ # We're doing tagging afterwards:
+ # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=568375
+ #git tag -s $(VERSION) -m "bootless $(VERSION)"
+ git checkout develop
+
+debian:
+ git checkout debian
+ git-import-orig --upstream-vcs-tag=$(VERSION) $(ARCHIVE)/bootless-$(VERSION).tar.bz2
+ # Fine tune debian/changelog prepared by git-dch
+ dch -e
+ git commit -a -m "Updating debian/changelog"
+ git-buildpackage --git-tag-only --git-sign-tags
+
web:
@ikiwiki --setup ikiwiki.setup