aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 1a8ed4c..2b0e93a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,6 +1,14 @@
+EXTRALIBS = easydialog tools
+dist_pkglib_DATA = $(EXTRALIBS)
+EXTRA_DIST = easydialog.in tools.in
-EXTRALIBRARIES = easydialog.sh
+edit = sed \
+ -e "s,@BASH\@,$(BASH),g"
-EXTRA_DIST = Makefile.am $(EXTRALIBRARIES)
+easydialog: easydialog.in
+ rm -f easydialog
+ $(edit) easydialog.in > easydialog
-dist_pkglib_DATA = $(EXTRALIBRARIES)
+tools: tools.in
+ rm -f tools
+ $(edit) tools.in > tools