aboutsummaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
Diffstat (limited to 'examples')
-rw-r--r--examples/Makefile.in56
-rw-r--r--examples/example.dup16
-rw-r--r--examples/example.ldap56
-rw-r--r--examples/example.rsync136
4 files changed, 183 insertions, 81 deletions
diff --git a/examples/Makefile.in b/examples/Makefile.in
index c4bea6d..3cfb394 100644
--- a/examples/Makefile.in
+++ b/examples/Makefile.in
@@ -1,9 +1,9 @@
-# Makefile.in generated by automake 1.11.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.5 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
-# Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -16,6 +16,23 @@
@SET_MAKE@
VPATH = @srcdir@
+am__make_dryrun = \
+ { \
+ am__dry=no; \
+ case $$MAKEFLAGS in \
+ *\\[\ \ ]*) \
+ echo 'am--echo: ; @echo "AM" OK' | $(MAKE) -f - 2>/dev/null \
+ | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
+ *) \
+ for am__flg in $$MAKEFLAGS; do \
+ case $$am__flg in \
+ *=*|--*) ;; \
+ *n*) am__dry=yes; break;; \
+ esac; \
+ done;; \
+ esac; \
+ test $$am__dry = yes; \
+ }
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
@@ -44,6 +61,11 @@ CONFIG_CLEAN_FILES =
CONFIG_CLEAN_VPATH_FILES =
SOURCES =
DIST_SOURCES =
+am__can_run_installinfo = \
+ case $$AM_UPDATE_INFO_DIR in \
+ n|no|NO) false;; \
+ *) (install-info --version) >/dev/null 2>&1;; \
+ esac
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
am__vpath_adj = case $$p in \
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
@@ -65,6 +87,12 @@ am__nobase_list = $(am__nobase_strip_setup); \
am__base_list = \
sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+am__uninstall_files_from_dir = { \
+ test -z "$$files" \
+ || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
am__installdirs = "$(DESTDIR)$(pkgdatadir)"
DATA = $(dist_pkgdata_DATA)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
@@ -189,8 +217,11 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
$(am__aclocal_m4_deps):
install-dist_pkgdataDATA: $(dist_pkgdata_DATA)
@$(NORMAL_INSTALL)
- test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
@list='$(dist_pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
+ if test -n "$$list"; then \
+ echo " $(MKDIR_P) '$(DESTDIR)$(pkgdatadir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)" || exit 1; \
+ fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
@@ -204,9 +235,7 @@ uninstall-dist_pkgdataDATA:
@$(NORMAL_UNINSTALL)
@list='$(dist_pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- test -n "$$files" || exit 0; \
- echo " ( cd '$(DESTDIR)$(pkgdatadir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(pkgdatadir)" && rm -f $$files
+ dir='$(DESTDIR)$(pkgdatadir)'; $(am__uninstall_files_from_dir)
tags: TAGS
TAGS:
@@ -261,10 +290,15 @@ install-am: all-am
installcheck: installcheck-am
install-strip:
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
- install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
- `test -z '$(STRIP)' || \
- echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
+ if test -z '$(STRIP)'; then \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ install; \
+ else \
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'" install; \
+ fi
mostlyclean-generic:
clean-generic:
diff --git a/examples/example.dup b/examples/example.dup
index 5e6b424..55ac565 100644
--- a/examples/example.dup
+++ b/examples/example.dup
@@ -194,6 +194,16 @@ exclude = /var/cache/backupninja/duplicity
# awsaccesskeyid =
# awssecretaccesskey =
+## RackSpace's CloudFiles username, API key, and authentication URL.
+## cfusername = YOUR_CF_USERNAME
+## cfapikey = YOUR_CF_API_KEY
+## cfauthurl = YOUR_CF_AUTH_URL
+##
+## Default:
+# cfusername =
+# cfapikey =
+# cfauthurl =
+
## FTP password, needed for backups using desturl = ftp://...
##
## Default:
@@ -207,12 +217,18 @@ exclude = /var/cache/backupninja/duplicity
## Default:
# bandwidthlimit = 0
+## duplicity < 0.6.17
+## ------------------
## passed directly to ssh, scp (and sftp in duplicity >=0.4.2)
## warning: sftp does not support all scp options, especially -i; as
## a workaround, you can use "-o <SSHOPTION>"
## an example setting would be:
## sshoptions = -o IdentityFile=/root/.ssh/id_rsa_duplicity
##
+## duplicity >= 0.6.17
+## ------------------
+## supports only "-o IdentityFile=..."
+##
## Default:
# sshoptions =
diff --git a/examples/example.ldap b/examples/example.ldap
deleted file mode 100644
index 174ed1d..0000000
--- a/examples/example.ldap
+++ /dev/null
@@ -1,56 +0,0 @@
-##
-## configuration file for openldap backups
-##
-## If the method is set to "slapcat", the LDIFs generated are
-## suitable for use with slapadd. As the entries are in database
-## order, not superior first order, they cannot be loaded with
-## ldapadd without being reordered.
-##
-
-## backupdir (default /var/backups/ldap): the destination for the backups
-# backupdir = /var/backups/ldap
-
-## conf (default /etc/ldap/slapd.conf): the location of the slapd.conf file.
-# conf = /etc/ldap/slapd.conf
-
-## databases (default all): either a space separated list of database
-## numbers or prefixes, or the keyword 'all'.
-# databases = all
-
-## compress (default yes): if set to yes, ldif exports are gzipped.
-# compress = yes
-
-## restart (default no): if set to yes, slapd is stopped before backups are
-## performed, and then started again after they have finished, this is necessary
-## if your backend is ldbm and your method is slapcat, but unnecessary otherwise.
-# restart = no
-
-## method (default ldapsearch): either 'ldapsearch' or 'slapcat'
-## ldapsearch is the safer method to do backups, but is slow, slapcat
-## is much faster, but should not be done on an ldbm backend unless you have
-## restart set to yes
-## NOTE: with the ldapsearch method passwordfile and binddn need to be set
-# method = ldapsearch
-
-## passwordfile (no default): this should be set to the file that contains
-## your ldap password, this is required for ldapsearch and not needed for slapcat
-## this file should have no newlines in it, echo -n "password" > passfile works.
-## NOTE: be sure to set the permissions on your password file appropriately
-## (hint: world readable is not appropriate)
-# passwordfile =
-
-## binddn (no default): set this to the DN of the user that the ldapsearch binds
-## to, not needed for slapcat
-# binddn =
-
-## ldaphost (no default): set this to your ldap host if it is not local
-# ldaphost =
-
-## ssl (default yes): if set to 'yes' then SSL connection will be
-## attempted to your ldaphost by using ldaps://
-# ssl = yes
-
-## tls (default no): if set to 'yes' then TLS connection will be
-## attempted to your ldaphost by using TLS extended operations (RFC2246,
-## RFC2830)
-# tls = no
diff --git a/examples/example.rsync b/examples/example.rsync
index 3c280ba..80365ae 100644
--- a/examples/example.rsync
+++ b/examples/example.rsync
@@ -18,6 +18,12 @@
# (see below) is set to 'yes'
#partition =
+# set to 1 if fsck should run on partition after the backup is made
+#fscheck =
+
+# set to 1 if partition is mounted read-only
+#read_only =
+
# backup partition mountpoint or backup main folder
# this doesn't need to be a real partition, but should be at least the
# main folder where the backup is being stored
@@ -26,19 +32,47 @@ mountpoint = /mnt/backup
# folder relative do mountpoint where the backup should be stored
backupdir = myserver
-# number of backup increments (min = 5)
-days = 7
+# temp folder
+#tmp = /tmp
-# set to 1 if fsck should run on partition after the backup is made
-#fscheck =
+# specify backup storage format: short, long or mirror (i.e, no rotations)
+#
+# In the short format, incremental backups are rotated every day the handler
+# runs an by a finite number of times (backup.0, backup.1, backup.1, etc), so
+# if you want to have incremental backups for longer periods (like months) you
+# have to configure rotations for 30 or more using the "days" parameter at the
+# [general] section in the handler config.
+#
+# The short format is better described here:
+# http://www.mikerubel.org/computers/rsync_snapshots/#Incremental
+#
+# The long format is inspired by the maildir handler and allows keeping backups
+# of longer periods (weeks and months) using less rotations as it stores
+# the increments in folders like daily.1, weekly.1, monthly.1 and has three
+# rotation parameters:
+#
+# keepdaily = number of daily backup increments
+# keepweekly = number of weekly backup increments
+# keepmonthly = number of monthly backup increments
+#
+format = short
-# set to 1 if $partition is mounted read-only
-#read_only =
+# for short storage format, specify the number of backup increments (min = 2, set to 1 or less to disable)
+#
+# Note that setting days = 0 is almost the same as using format = mirror except
+# that with the days config your backup gets a .0 suffix at the destination
+# folder, making it easier to turn it later to an incremental backup.
+#
+days = 7
+
+# for long storage format, specify the number of daily backup increments
+#keepdaily = 7
+
+# for long storage format, specify the number of weekly backup increments
+#keepweekly = 3
-# use this if you need a lockfile to be kept during backup execution
-# this is an useful feature in case you have some tasks that should
-# know if the backup is running or not
-#lockfile =
+# for long storage format, specify the number of monthly backup increments
+#keepmonthly = 1
# rsync command nice level
#nicelevel = 0
@@ -49,6 +83,9 @@ days = 7
# temp folder
#tmp = /tmp
+# set to "yes" if you want to use multiconnection ssh support
+#multiconnection = no
+
[source]
# where the data to be backed up is (local or remote)
@@ -57,6 +94,12 @@ days = 7
# if remote source, specify the hostname or IP
#host =
+# remote port number (remote source only)
+#port = 22
+
+# remote user name (remote source only)
+#user =
+
# when "yes", test the connection for a remote source before backup
#testconnect = no
@@ -76,32 +119,97 @@ exclude_vserver = excluded_vserver2
# ssh command line (remote only)
#ssh = ssh
+# ssh or rsync (remote source only)
+#protocol = ssh
+
# rsync program
# it defaults to $RSYNC value from backupninja.conf
#rsync = $RSYNC
# rsync command options
-#rsync_options = "-av --delete"
+#rsync_options = "-av --delete --recursive"
# when set to 1, use numeric ids instead of user/group mappings on rsync
-#numericids = 0
+#numericids =
# if set to 1, compress data on rsync (remote source only)
#compress = 0
-# set a badnwidth limit in KB/s (remote source only)
+# set a bandwidth limit in KB/s (remote source only)
#bandwidthlimit =
# remote rsync program (remote source only)
#remote_rsync = rsync
+# ssh key file (remote source only)
+#id_file = /root/.ssh/id_dsa
+
+# set to "yes" to rsync use a batch file as source
+#batch = no
+
+# folder where the batch file is located
+#batchbase =
+
+# set yes if you want rsync to use a file list source
+#filelist = no
+
+# folder where the file list is placed
+#filelistbase =
+
+[dest]
+
+# backup destination type (local or remote)
+#dest = local
+
+# when "yes", test the connection for a remote source before backup
+#testconnect = no
+
+# ssh command line (remote dest only)
+#ssh = ssh
+
+# ssh or rsync (remote dest only)
+#protocol = ssh
+
+# when set to 1, use numeric ids instead of user/group mappings on rsync
+#numericids =
+
+# if set to 1, compress data on rsync (remote source only)
+#compress = 0
+
+# destination host name (remote destination only)
+#host =
+
+# remote port number (remote destination only)
+#port = 22
+
+# remote user name (remote destination only)
+#user =
+
+# ssh key file (remote destination only)
+#id_file = /root/.ssh/id_dsa
+
+# set a bandwidth limit in KB/s (remote destination only)
+#bandwidthlimit =
+
+# remote rsync program (remote dest only)
+#remote_rsync = rsync
+
+# set to "yes" to rsync write a batch file from the changes
+#batch = no
+
+# folder where the batch file should be written
+#batchbase = /var/backups/rsync/batches
+
+# set to yes so rsync use the --fake-super flag (remote destination only)
+#fakesuper = yes
+
# This section is used to stop and start services that should be turned of
# during the backup procedure.
#
#[services]
#
# absolute path where scripts are located
-#initscripts =
+#initscripts = /etc/init.d
#
# script name to be stoped at the begining of the backup and started at its end
#service =