aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5781ce7..99ebdee 100644
--- a/configure.in
+++ b/configure.in
@@ -26,6 +26,19 @@ AC_CHECK_PROGS(AWK, awk)
if test x$AWK = "x"; then
AC_MSG_ERROR([awk is required])
fi
+AC_CHECK_PROG(ac_cv_have_rpm, rpm, "yes", "no")
+if test "x$ac_cv_have_rpm" = "xyes"; then
+ rpm --define '_topdir /tmp' > /dev/null 2>&1
+ AC_MSG_CHECKING(to see if we can redefine _topdir)
+ if test $? -eq 0 ; then
+ AC_MSG_RESULT(yes)
+ HAVE_RPM=yes
+ else
+ AC_MSG_RESULT(no. You'll have to build packages manually.)
+ HAVE_RPM=no
+ fi
+fi
+AC_SUBST(HAVE_RPM)
AC_SUBST([CFGDIR], "${sysconfdir}")