aboutsummaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2009-02-19 12:20:44 -0500
committerMicah Anderson <micah@riseup.net>2009-02-19 12:20:44 -0500
commit27a7859c42394a78c16b24f0d08ca28667bb1efa (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /examples
parent386c4275946520bc590428e730a9d515155436a0 (diff)
downloadbackupninja-27a7859c42394a78c16b24f0d08ca28667bb1efa.tar.gz
backupninja-27a7859c42394a78c16b24f0d08ca28667bb1efa.tar.bz2
creating a debian only branch out of what used to be a subversion repository
Diffstat (limited to 'examples')
-rw-r--r--examples/Makefile.am9
-rw-r--r--examples/example.dup147
-rw-r--r--examples/example.ldap51
-rw-r--r--examples/example.maildir58
-rw-r--r--examples/example.makecd31
-rw-r--r--examples/example.mysql89
-rw-r--r--examples/example.pgsql23
-rw-r--r--examples/example.rdiff120
-rw-r--r--examples/example.rsync127
-rw-r--r--examples/example.sh2
-rw-r--r--examples/example.svn26
-rw-r--r--examples/example.sys70
-rw-r--r--examples/example.trac16
13 files changed, 0 insertions, 769 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
deleted file mode 100644
index a2ffbb2..0000000
--- a/examples/Makefile.am
+++ /dev/null
@@ -1,9 +0,0 @@
-
-EXAMPLES = example.dup example.ldap example.makecd example.mysql \
- example.pgsql example.rdiff example.sh example.rsync \
- example.svn example.sys example.trac example.maildir
-
-EXTRA_DIST = $(EXAMPLES)
-
-dist_pkgdata_DATA = $(EXAMPLES)
-
diff --git a/examples/example.dup b/examples/example.dup
deleted file mode 100644
index 830a47d..0000000
--- a/examples/example.dup
+++ /dev/null
@@ -1,147 +0,0 @@
-
-# passed directly to duplicity
-#options = --verbosity 8
-
-# default is 0, but set to 19 if you want to lower the priority.
-nicelevel = 19
-
-# default is yes. set to no to skip the test if the remote host is alive
-#testconnect = no
-
-# temporary directory used by duplicity
-# (default = /tmp or /usr/tmp, depending on the system)
-#tmpdir = /var/tmp/duplicity
-
-######################################################
-## gpg section
-## (how to encrypt and optionally sign the backups)
-##
-## WARNING: old (pre-0.9.4) example.dup used to give wrong information about
-## the way the following options are used. Please read the following
-## carefully.
-##
-## If the encryptkey variable is set:
-## - data is encrypted with the GnuPG public key specified by the encryptkey
-## variable
-## - if signing is enabled, data is signed with the GnuPG private
-## key specified by the signkey variable
-## - the password variable is used to unlock the GnuPG key(s) used
-## for encryption and (optionnal) signing
-##
-## If the encryptkey option is not set:
-## - data signing is not possible
-## - the password variable is used to encrypt the data with symmetric
-## encryption: no GnuPG key pair is needed
-
-[gpg]
-
-# when set to yes, encryptkey variable must be set below; if you want to use
-# two different keys for encryption and signing, you must also set the signkey
-# variable below.
-# default is no, for backwards compatibility with backupninja <= 0.5.
-sign = yes
-
-# ID of the GnuPG public key used for data encryption.
-# if not set, symmetric encryption is used, and data signing is not possible.
-encryptkey = 04D9EA79
-
-# ID of the GnuPG private key used for data signing.
-# if not set, encryptkey will be used.
-#signkey = 04D9EA79
-
-# password
-# NB: neither quote this, nor should it contain any quotes
-password = a_very_complicated_passphrase
-
-######################################################
-## source section
-## (where the files to be backed up are coming from)
-
-[source]
-
-# A few notes about includes and excludes:
-# 1. include, exclude and vsinclude statements support globbing with '*'
-# 2. Symlinks are not dereferenced. Moreover, an include line whose path
-# contains, at any level, a symlink to a directory, will only have the
-# symlink backed-up, not the target directory's content. Yes, you have to
-# dereference yourself the symlinks, or to use 'mount --bind' instead.
-# Example: let's say /home is a symlink to /mnt/crypt/home ; the following
-# line will only backup a "/home" symlink ; neither /home/user nor
-# /home/user/Mail will be backed-up :
-# include = /home/user/Mail
-# A workaround is to 'mount --bind /mnt/crypt/home /home' ; another one is to
-# write :
-# include = /mnt/crypt/home/user/Mail
-# 3. All the excludes come after all the includes. The order is not otherwise
-# taken into account.
-
-# files to include in the backup
-include = /var/spool/cron/crontabs
-include = /var/backups
-include = /etc
-include = /root
-include = /home
-include = /usr/local/bin
-include = /usr/local/sbin
-include = /var/lib/dpkg/status
-include = /var/lib/dpkg/status-old
-
-# If vservers = yes in /etc/backupninja.conf then the following variables can
-# be used:
-# vsnames = all | <vserver1> <vserver2> ... (default = all)
-# vsinclude = <path>
-# vsinclude = <path>
-# ...
-# Any path specified in vsinclude is added to the include list for each vserver
-# listed in vsnames (or all if vsnames = all, which is the default).
-#
-# For example, vsinclude = /home will backup the /home directory in every
-# vserver listed in vsnames. If you have 'vsnames = foo bar baz', this
-# vsinclude will add to the include list /vservers/foo/home, /vservers/bar/home
-# and /vservers/baz/home.
-# Vservers paths are derived from $VROOTDIR.
-
-# files to exclude from the backup
-exclude = /home/*/.gnupg
-
-######################################################
-## destination section
-## (where the files are copied to)
-
-[dest]
-
-# perform an incremental backup? (default = yes)
-# if incremental = no, perform a full backup in order to start a new backup set
-#incremental = yes
-
-# how many days of data to keep ; default is 60 days.
-# (you can also use the time format of duplicity)
-# 'keep = yes' means : do not delete old data, the remote host will take care of this
-#keep = 60
-#keep = yes
-
-# full destination URL, in duplicity format; if set, desturl overrides
-# sshoptions, destdir, desthost and destuser; it also disables testconnect and
-# bandwithlimit. For details, see duplicity manpage, section "URL FORMAT".
-#desturl = file:///usr/local/backup
-#desturl = rsync://user@other.host//var/backup/bla
-
-# bandwith limit, in kbit/s ; default is 0, i.e. no limit
-#bandwidthlimit = 128
-
-# passed directly to ssh, scp (and sftp in duplicity >=0.4.2)
-# warning: sftp does not support all scp options, especially -i; as
-# a workaround, you can use "-o <SSHOPTION>"
-sshoptions = -o IdentityFile=/root/.ssh/id_dsa_duplicity
-
-# put the backups under this directory
-destdir = /backups
-
-# the machine which will receive the backups
-desthost = backuphost
-
-# make the files owned by this user
-# note: you must be able to ssh backupuser@backhost
-# without specifying a password (if type = remote).
-destuser = backupuser
-
diff --git a/examples/example.ldap b/examples/example.ldap
deleted file mode 100644
index ee7c57d..0000000
--- a/examples/example.ldap
+++ /dev/null
@@ -1,51 +0,0 @@
-##
-## configuration file for openldap backups
-##
-## If the method is set to "slapcat", the LDIFs generated are
-## suitable for use with slapadd. As the entries are in database
-## order, not superior first order, they cannot be loaded with
-## ldapadd without being reordered.
-##
-
-## backupdir (default /var/backups/ldap): the destination for the backups
-# backupdir = /var/backups/ldap
-
-## conf (default /etc/ldap/slapd.conf): the location of the slapd.conf file.
-# conf = /etc/ldap/slapd.conf
-
-## databases (default all): either a space separated list of database
-## numbers or prefixes, or the keyword 'all'.
-# databases = all
-
-## compress (default yes): if set to yes, ldif exports are gzipped.
-# compress = yes
-
-## restart (default no): if set to yes, slapd is stopped before backups are
-## performed, and then started again after they have finished, this is necessary
-## if your backend is ldbm and your method is slapcat, but unnecessary otherwise.
-# restart = no
-
-## method (default ldapsearch): either 'ldapsearch' or 'slapcat'
-## ldapsearch is the safer method to do backups, but is slow, slapcat
-## is much faster, but should not be done on an ldbm backend unless you have
-## restart set to yes
-## NOTE: with the ldapsearch method passwordfile and binddn need to be set
-# method = ldapsearch
-
-## passwordfile (no default): this should be set to the file that contains
-## your ldap password, this is required for ldapsearch and not needed for slapcat
-## this file should have no newlines in it, echo -n "password" > passfile works.
-## NOTE: be sure to set the permissions on your password file appropriately
-## (hint: world readable is not appropriate)
-# passwordfile =
-
-## binddn (no default): set this to the DN of the user that the ldapsearch binds
-## to, not needed for slapcat
-# binddn =
-
-## ldaphost (no default): set this to your ldap host if it is not local
-# ldaphost =
-
-## tls (default yes): if set to 'yes' then TLS connection will be
-## attempted to your ldaphost by using the URI base ldaps: otherwise ldap: will be used
-# tls = yes \ No newline at end of file
diff --git a/examples/example.maildir b/examples/example.maildir
deleted file mode 100644
index 8898a78..0000000
--- a/examples/example.maildir
+++ /dev/null
@@ -1,58 +0,0 @@
-##
-## This is an example maildir configuration file.
-##
-## The maildir handler slowly creates a backup of each user's
-## maildir to a remote server. It is designed to be run with
-## low overhead in terms of CPU and bandwidth, so it runs pretty
-## slow. Hardlinking is used to save storage space. The actual
-## maildir is stored within each snapshot directory.
-##
-## The basic algorithm is to rsync each maildir individually,
-## and to use hard links for retaining historical data.
-##
-## We handle each maildir individually because it becomes very
-## unweldy to hardlink and rsync many hundreds of thousands
-## of files at once. It is much faster to take on smaller
-## chunks at a time.
-##
-## Any maildir which is deleted from the source will be moved to
-## "deleted" directory in the destination. It is up to you to
-## periodically remove this directory or old maildirs in it.
-##
-## Note: This handler assumes that the remote shell is set to bash
-##
-## The defaults are useful in most cases, just make sure
-## to configure the source and destination information
-
-when = everyday at 21:00
-
-## each users maildir will contain these files:
-## daily.1, daily.2, daily.3, daily.4, daily.5, weekly.1, weekly.2,
-## weekly.3, monthly.1
-## if keepdaily is 5, keepweekly is 3, and keepmonthly is 1
-keepdaily = 5
-keepweekly = 3
-keepmonthly = 1
-
-# directory which contains all the maildirs
-srcdir = /maildir/riseup.net
-
-# the srcdir is expected to contain the following subdirectories. Each
-# of these will contain the user's Maildirs which start with these
-# letters
-srcsubdirs = 0 1 2 3 4 5 6 7 8 9 a b c d e f g h i j k l m n o p q r s t u v w x y z
-
-# put the backups under this directory
-destdir = /crypta/maildir/riseup.net
-desthost = kakapo-pn
-
-# For the backup rotation to work, destuser must be able to run
-# arbitrary bash commands on the desthost.
-destuser = backer
-
-# remove any maildirs from backup which might have been deleted
-remove = yes
-
-# use a ssh-mux to reuse connections, see the following article
-# http://www.debian-administration.org/articles/290 for an example
-multiconnection = notset
diff --git a/examples/example.makecd b/examples/example.makecd
deleted file mode 100644
index b01094e..0000000
--- a/examples/example.makecd
+++ /dev/null
@@ -1,31 +0,0 @@
-
-# TYP is cd or dvd AS WELL AS the disk inside!!
-burnertype = cd
-
-# system (yes) or directory/files (no)
-# this function not yet implemented
-#system = yes
-
-# location for image file
-backupdir = /var/backups/makecd
-
-# image filename
-imagefile = example.iso
-
-# iso or burn to cd/dvd?
-isoonly = no
-
-# cd/dvd burner device
-device=/dev/hdc
-
-# base directory to include in the backup
-target = /
-
-# files or directories to be excluded
-exclude = /proc
-exclude = /lost+found
-exclude = /tmp
-
-# backupninja will perfrom this at gvien date/time
-when = wednesday at 02:00
-
diff --git a/examples/example.mysql b/examples/example.mysql
deleted file mode 100644
index de9651f..0000000
--- a/examples/example.mysql
+++ /dev/null
@@ -1,89 +0,0 @@
-### backupninja mysql config file ###
-
-databases = all
-backupdir = /var/backups/mysql
-hotcopy = no
-sqldump = yes
-compress = yes
-
-### authentication ###
-
-# three authentication methods:
-#
-# 1. setting the user, so that /home/user/.my.cnf is used.
-# user = some-unix-user
-#
-# 2. specifying the mysql dbuser and dbpassword,
-# which generates a temporary .my.cnf in /root/.my.cnf
-# dbusername = <some-mysql-user>
-# dbpassword = <password>
-#
-# 3. specify which config file to use with configfile
-# (this option does not work with hotcopy)
-# configfile = /etc/mysql/debian.cnf
-#
-# if user and dbusername are not specified, the default is to use
-# /etc/mysql/debian.cnf for configfile.
-
-### all options ###
-
-# configfile = < path/to/file > (default = /etc/mysql/debian.cnf)
-# The config file is passed to mysql with --defaults-file.
-# On debian, this default will allow backupninja to make backups
-# of mysql without configuring any additional options.
-# (this option is not compatible with "user" or "dbusername").
-#
-# user = <user> (default = root)
-# Run mysql commands as 'user'. A valid .my.cnf must exist with a
-# database username and password in the user's home directory.
-# (this option is not compatible with "configfile" or "dbusername").
-#
-# dbusername = <dbuser> (no default)
-# The user must have access to the databases specified later.
-# (this option is not compatible with "configfile" or "user").
-#
-# dbpassword = <dbpass> (no default)
-# The password used with dbusername. this password will NOT be passed
-# on the command line and is not readable using "ps aux".
-#
-# dbhost = <host> (default = localhost)
-# only localhost works right now.
-#
-# databases = < all | db1 db2 db3 > (default = all)
-# which databases to backup. should either be the word 'all' or a
-# space separated list of database names.
-#
-# nodata = < db.table1 db.table2 db.table3 > (no default)
-# only dump the structure for the database tables listed here, this means
-# no data contained in these tables will be dumped. This is very useful
-# to backup databases that have tables with large amounts of cache data that
-# isn't necessary to backup, but you still need the structure to exist
-# on a restore. You *must* specify the table as part of a database, such
-# as "drupal.cache", where the database name is "drupal" and the table that
-# you do not want to dump the data for is called "cache".
-#
-# backupdir = < path/to/destination > (default = /var/backups/mysql)
-# where to dump the backups. hotcopy backups will be in a subdirectory
-# 'hotcopy' and sqldump backups will be in a subdirectory 'sqldump'
-#
-# hotcopy = < yes | no > (default = no)
-# make a backup of the actual database binary files using mysqlhotcopy.
-#
-# sqldump = < yes | no > (default = no)
-# make a backup using mysqldump. this creates text files with sql commands
-# sufficient to recontruct the database.
-#
-# sqldumpoptions = <options>
-# (default = --lock-tables --complete-insert --add-drop-table --quick --quote-names)
-# arguments to pass to mysqldump
-#
-# compress = < yes | no > (default = yes)
-# if yes, compress the sqldump output.
-#
-# vsname = <vserver> (no default)
-# what vserver to operate on (only used if vserver = yes
-# in /etc/backupninja.conf), if you do not specify a vsname the
-# host will be operated on
-#
-# NB: databases = all doesn't seem to work with hotcopy = yes
-# when vsname is specified, I would like to know how to fix this.
diff --git a/examples/example.pgsql b/examples/example.pgsql
deleted file mode 100644
index 42f045e..0000000
--- a/examples/example.pgsql
+++ /dev/null
@@ -1,23 +0,0 @@
-### backupninja PostgreSQL config file ###
-
-# vsname = <vserver> (no default)
-# what vserver to operate on, only used if vserver = yes in /etc/backupninja.conf
-# if you do not specify a vsname the host will be operated on
-# Note: if operating on a vserver, $VROOTDIR will be prepended to backupdir.
-
-# backupdir = <dir> (default: /var/backups/postgres)
-# where to dump the backups
-
-# databases = < all | db1 db2 db3 > (default = all)
-# which databases to backup. should either be the word 'all' or a
-# space separated list of database names.
-# Note: when using 'all', pg_dumpall is used instead of pg_dump, which means
-# that cluster-wide data (such as users and groups) are saved.
-
-# compress = < yes | no > (default = yes)
-# if yes, compress the pg_dump/pg_dumpall output.
-
-### You can also set the following variables in /etc/backupninja.conf:
-# PGSQLDUMP: pg_dump path (default: /usr/bin/pg_dump)
-# PGSQLDUMPALL: pg_dumpall path (default: /usr/bin/pg_dumpall)
-# PGSQLUSER: user running PostgreSQL (default: postgres)
diff --git a/examples/example.rdiff b/examples/example.rdiff
deleted file mode 100644
index 3767f9b..0000000
--- a/examples/example.rdiff
+++ /dev/null
@@ -1,120 +0,0 @@
-##
-## This is an example rdiff-backup configuration file.
-## The defaults are useful in most cases, just make sure
-## to configure the destination host and user.
-##
-
-## passed directly to rdiff-backup
-# options = --force
-
-## default is 0, but set to 19 if you want to lower the priority.
-# nicelevel = 19
-
-## default is yes. set to no to skip the test if the remote host is alive
-# testconnect = no
-
-## default is not to limit bandwidth.
-## set to a number in bytes/second to limit bandwidth usage. Use a negative
-## number to set a limit that will never be exceeded, or a positive number
-## to set a target average bandwidth use. cstream is required. See cstream's
-## -t option for more information. 62500 bytes = 500 Kb (.5 Mb)
-# bwlimit = 62500
-
-## should backupninja ignore the version differences between source and remote
-## rdiff-backup? (default: no)
-## This could be useful if the version differences between rdiff-backup instances
-## on remote and local side are different, and you are certain there are no
-## problems in using mis-matched versions and want to get beyond this check.
-## An example usage could be the remote side has its authorized_keys configured
-## with command="rdiff-backup --server" to allow for restricted yet automated
-## password-less backups
-# ignore_version = no
-
-######################################################
-## source section
-## (where the files to be backed up are coming from)
-
-[source]
-
-# an optional subdirectory below 'directory' (see [dest])
-label = thishostname
-
-# type can be "local" or "remote"
-type = local
-
-# only use if '[source] type = remote'
-#host = srchost
-#user = srcuser
-
-# how many days of data to keep
-# (you can also use the time format of rdiff-backup, e.g. 6D5h)
-# (to keep everything, set this to yes)
-#keep = yes
-keep = 60
-
-# A few notes about includes and excludes:
-# 1. include, exclude and vsinclude statements support globbing with '*'
-# 2. Symlinks are not dereferenced. Moreover, an include line whose path
-# contains, at any level, a symlink to a directory, will only have the
-# symlink backed-up, not the target directory's content. Yes, you have to
-# dereference yourself the symlinks, or to use 'mount --bind' instead.
-# Example: let's say /home is a symlink to /mnt/crypt/home ; the following
-# line will only backup a "/home" symlink ; neither /home/user nor
-# /home/user/Mail will be backed-up :
-# include = /home/user/Mail
-# A workaround is to 'mount --bind /mnt/crypt/home /home' ; another one is to
-# write :
-# include = /mnt/crypt/home/user/Mail
-# 3. All the excludes come after all the includes. The order is not otherwise
-# taken into account.
-
-# files to include in the backup
-include = /var/spool/cron/crontabs
-include = /var/backups
-include = /etc
-include = /root
-include = /home
-include = /usr/local/bin
-include = /usr/local/sbin
-include = /var/lib/dpkg/status
-include = /var/lib/dpkg/status-old
-
-# If vservers = yes in /etc/backupninja.conf then the following variables can
-# be used:
-# vsnames = all | <vserver1> <vserver2> ... (default = all)
-# vsinclude = <path>
-# vsinclude = <path>
-# ...
-# Any path specified in vsinclude is added to the include list for each vserver
-# listed in vsnames (or all if vsnames = all, which is the default).
-#
-# For example, vsinclude = /home will backup the /home directory in every
-# vserver listed in vsnames. If you have 'vsnames = foo bar baz', this
-# vsinclude will add to the include list /vservers/foo/home, /vservers/bar/home
-# and /vservers/baz/home.
-# Vservers paths are derived from $VROOTDIR.
-
-# files to exclude from the backup
-#exclude = /home/*/.gnupg
-
-######################################################
-## destination section
-## (where the files are copied to)
-
-[dest]
-
-# type can be "local" or "remote"
-type = remote
-
-# put the backups under this directory
-directory = /backups
-
-# the machine which will receive the backups.
-# only use if "[dest] type = remote"
-host = backuphost
-
-# make the files owned by this user. you must be able to
-# `su -c "ssh backupuser@backhost"` without specifying a password.
-# only use if "[dest] type = remote"
-user = backupuser
-
diff --git a/examples/example.rsync b/examples/example.rsync
deleted file mode 100644
index 9053f3e..0000000
--- a/examples/example.rsync
+++ /dev/null
@@ -1,127 +0,0 @@
-#
-# rsync handler example file
-#
-# Mandatory options are uncommented with sugested values
-# Other options are commented out with their default values
-#
-# Note: You dont need to manually specify vservers using "include = /vservers".
-# They're automatically backuped if vserver is set to "yes" on you backupninja.conf.
-
-[general]
-
-# rsync log file
-#log = /var/log/backup/rsync.log
-
-# partition device where the backup lives
-# just use this option if your data is backed up in a separate partition and
-# you want backupninja to fsck it; this option will just be used if fscheck
-# (see below) is set to 'yes'
-#partition =
-
-# backup partition mountpoint or backup main folder
-# this doesn't need to be a real partition, but should be at least the
-# main folder where the backup is being stored
-mountpoint = /mnt/backup
-
-# folder relative do mountpoint where the backup should be stored
-backupdir = myserver
-
-# number of backup increments (min = 5)
-days = 7
-
-# set to 1 if fsck should run on partition after the backup is made
-#fscheck =
-
-# set to 1 if $partition is mounted read-only
-#read_only =
-
-# use this if you need a lockfile to be kept during backup execution
-# this is an useful feature in case you have some tasks that should
-# know if the backup is running or not
-#lockfile =
-
-# rsync command nice level
-#nicelevel = 0
-
-# set to "yes" if your system isnt handling timestamps correctly
-#enable_mv_timestamp_bug = no
-
-# temp folder
-#tmp = /tmp
-
-[source]
-
-# where the data to be backed up is (local or remote)
-#from = local
-
-# if remote source, specify the hostname or IP
-#host =
-
-# when "yes", test the connection for a remote source before backup
-#testconnect = no
-
-# include folder on backup
-include = /etc
-include = /var
-
-# exclude folder on backup
-exclude = exclude_folder1
-exclude = exclude_folder2
-
-# exlude some vserver from backup
-# this is used only if vservers = yes on backupninja.conf
-exclude_vserver = excluded_vserver1
-exclude_vserver = excluded_vserver2
-
-# ssh command line (remote only)
-#ssh = ssh
-
-# rsync program
-# it defaults to $RSYNC value from backupninja.conf
-#rsync = $RSYNC
-
-# rsync command options
-#rsync_options = "-av --delete"
-
-# when set to 1, use numeric ids instead of user/group mappings on rsync
-#numericids = 0
-
-# if set to 1, compress data on rsync (remote source only)
-#compress = 0
-
-# set a badnwidth limit in kbps (remote source only)
-#bandwidthlimit =
-
-# remote rsync program (remote source only)
-#remote_rsync = rsync
-
-# This section is used to stop and start services that should be turned of
-# during the backup procedure.
-#
-#[services]
-#
-# absolute path where scripts are located
-#initscripts =
-#
-# script name to be stoped at the begining of the backup and started at its end
-#service =
-
-# You can also specify some system comands if you don't want the default system values
-# by enabling the section below.
-#
-#[system]
-#
-# rm command
-#rm = rm
-#
-# cp command
-#cp = cp
-#
-# touch command
-#touch = touch
-#
-# mv command
-#mv = mv
-#
-# fsck command
-#fsck = fsck
diff --git a/examples/example.sh b/examples/example.sh
deleted file mode 100644
index f02f026..0000000
--- a/examples/example.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-
-dpkg --get-selections > /var/backups/dpkg-selections.txt
diff --git a/examples/example.svn b/examples/example.svn
deleted file mode 100644
index ea43601..0000000
--- a/examples/example.svn
+++ /dev/null
@@ -1,26 +0,0 @@
-##
-## Perform a hot backup of subversion repositories.
-##
-## REQUIRES: apt-get install subversion-tools
-##
-## This file can be empty, the defaults are usually good.
-##
-
-## where subversion data lives
-# src = /var/lib/svn
-
-## where to save the backups to
-# dest = /var/backups/svn
-
-## where to save temporary backups
-## (if successful, $tmp is moved to $dest)
-# tmp = /var/backups/svn.tmp
-
-## the hotbackup program to use.
-## svnadmin hotcopy now exists, the following script is located
-## in /usr/share/doc/subversion/examples now if you wish to use
-## it instead
-# HOTBACKUP = /usr/lib/subversion/hot-backup.py
-
-## the name of the vserver containing svn, if using vservers
-# vsname =
diff --git a/examples/example.sys b/examples/example.sys
deleted file mode 100644
index fe34646..0000000
--- a/examples/example.sys
+++ /dev/null
@@ -1,70 +0,0 @@
-#
-# this config file will save various reports of vital system information.
-# by default, all the reports are saved in /var/backups.
-#
-# requires dpkg, debconf-utils, sfdisk, and hwinfo
-#
-# (1) a capture of the debconf package selection states. This file
-# can be used to restore the answers to debconf questions for
-# packages that you will be installing through (2) below. To
-# do this, run: "debconf-set-selections < debconfsel.txt"
-#
-# (2) a list of all the packages installed and removed.
-# this file can be used to restore the state of installed packages
-# by running "dpkg --set-selections < dpkg-selections.txt and
-# then run "apt-get -u dselect-upgrade". If you have the
-# debconf-set-selections file from (1), you should restore those first.
-#
-# (3) the partition table of all disks.
-# this partition table can be used to format another disk of
-# the same size. this can be handy if using software raid and
-# you have a disk go bad. just replace the disk and partition it
-# by running "sfdisk /dev/sdb < partitions.sdb.txt"
-# (MAKE SURE YOU PARTITION THE CORRECT DISK!!!)
-#
-# (4) hardware information.
-# detailed information on most important aspects of the hardware.
-#
-# (5) the Luks header of every Luks block device, if option luksheaders
-# is enabled.
-# in case you (have to) scramble such a Luks header (for some time),
-# and restore it later by running "dd if=luksheader.sda2.bin of=/dev/sda2"
-# (MAKE SURE YOU PASS THE CORRECT DEVICE AS of= !!!)
-#
-# (6) LVM metadata for every detected volume group, if "lvm = yes"
-#
-
-# here are the defaults, commented out:
-
-# The output from the sys handler will be placed in $parentdir
-# parentdir = /var/backups
-# packages = yes
-# packagesfile = /var/backups/dpkg-selections.txt
-# selectionsfile = /var/backups/debconfsel.txt
-
-# partitions = yes
-# NOTE: the __star__ below will be replaced by the disks found on the
-# system (e.g. partitions.sda.txt, partitions.sdb.txt). If you change
-# the partitionsfile default below, be sure to include the __star__
-# replacement in the filename, or you will get one file for only one disk,
-# the others being written to the same file, and then overwritten by the next.
-# partitionsfile = /var/backups/partitions.__star__.txt
-# dosfdisk = yes
-
-# hardware = yes
-# hardwarefile = /var/backups/hardware.txt
-# dohwinfo = yes
-
-# luksheaders = no
-# NOTE: the __star__ below will be replaced by the Luks partitions found on the
-# system (e.g. luksheader.sda2.bin, luksheader.sdb3.bin). If you change
-# the luksheadersfile default below, be sure to include the __star__
-# replacement in the filename, or you will get one file for only one partition,
-# the others being written to the same file, and then overwritten by the next.
-# luksheadersfile = /var/backups/luksheader.__star__.bin
-
-# lvm = no
-
-# If vservers = yes in /etc/backupninja.conf then the following variables can
-# be used:
-# vsnames = all | <vserver1> <vserver2> ... (default = all)
diff --git a/examples/example.trac b/examples/example.trac
deleted file mode 100644
index 645998e..0000000
--- a/examples/example.trac
+++ /dev/null
@@ -1,16 +0,0 @@
-##
-## Perform backups of trac environment
-##
-## REQUIRES: apt-get install trac
-##
-## This file can be empty, the defaults are usually good.
-##
-
-## where one or more Trac environments live
-src = /var/lib/trac
-
-## where to save the backups to
-dest = /var/backups/trac
-
-## where to save temporary backups
-tmp = /var/backups/trac.tmp