aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2006-01-20 00:10:58 +0000
committerMicah Anderson <micah@riseup.net>2006-01-20 00:10:58 +0000
commiteac987023c4ef155d58a3cb34f9a21d9043f65bb (patch)
tree4b26f2ed1aa80badab243ed51a6c438f1c24db5b /configure.in
parentcfb621ce68bb784958ba3589c299ca06f2b105f5 (diff)
downloadbackupninja-eac987023c4ef155d58a3cb34f9a21d9043f65bb.tar.gz
backupninja-eac987023c4ef155d58a3cb34f9a21d9043f65bb.tar.bz2
configure script should not be in svn, but instead generated on release
configure.in modified to be more selective about finding bash configure.in modified for 0.9.3 release autogen.sh modified to create config.guess and config.sub for release changelog updated about autoconf changes Removed /bin/bash TODO line
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 17 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 6f2a11e..c7ba599 100644
--- a/configure.in
+++ b/configure.in
@@ -1,27 +1,31 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_INIT([backupninja],[0.9.2],[backupninja@lists.riseup.net])
+AC_INIT([backupninja],[0.9.3],[backupninja@lists.riseup.net])
AC_CONFIG_SRCDIR([src/backupninja.in])
-#AC_CONFIG_HEADERS([config.sh])
AM_INIT_AUTOMAKE
# Checks for programs.
-AC_PATH_PROGS([BASH], [bash])
-#AC_PATH_PROGS([PERL], [perl])
-#AC_DEFINE([MYVERSION], [5.6])
-#AC_DEFINE_UNQUOTED([MYDIR], "${sysconfdir}")
-#AC_DEFINE([SYSCONFDIR], [$sysconfdir], [System config dir])
-AC_SUBST([CFGDIR], "${sysconfdir}")
-
-# Checks for libraries.
+# BASH may already be set in the shell, if the admin then changes the
+# the /bin/sh symlink to a non-bash shell, all hell will break lose.
+unset BASH
+AC_PATH_PROGS([BASH], [bash], [/bin/bash], [$PATH:/bin:/usr/bin:/usr/sbin])
+if test x$BASH = "x"; then
+ AC_MSG_ERROR([bash is required])
+fi
-# Checks for header files.
+AC_CHECK_PROGS(SED, sed)
+if test x$SED = "x"; then
+ AC_MSG_ERROR([sed is required])
+fi
-# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_PROGS(AWK, awk)
+if test x$AWK = "x"; then
+ AC_MSG_ERROR([awk is required])
+fi
-# Checks for library functions.
+AC_SUBST([CFGDIR], "${sysconfdir}")
AC_CONFIG_FILES([Makefile
etc/Makefile