aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2007-02-23 18:04:04 +0000
committerMicah Anderson <micah@riseup.net>2007-02-23 18:04:04 +0000
commit05c26446ed65681528387f6c66473c61eebe7224 (patch)
treebbbd9bfce2bda17e0d399d1c97959c4a2937c6eb /configure.in
parentd15a347be54fea3ae44c595b454b22fb41149271 (diff)
downloadbackupninja-05c26446ed65681528387f6c66473c61eebe7224.tar.gz
backupninja-05c26446ed65681528387f6c66473c61eebe7224.tar.bz2
updated autotools abstraction to properly pick up different awk, sed,
and md5sum locations
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 16 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 2b8c269..716c175 100644
--- a/configure.in
+++ b/configure.in
@@ -12,20 +12,30 @@ AM_INIT_AUTOMAKE
# BASH may already be set in the shell, if the admin then changes the
# the /bin/sh symlink to a non-bash shell, all hell will break lose.
unset BASH
-AC_PATH_PROGS([BASH], [bash], [/bin/bash], [$PATH:/bin:/usr/bin:/usr/sbin])
-if test x$BASH = "x"; then
+AC_PATH_PROGS(BASH, bash, "no", [$PATH:/bin:/usr/bin:/usr/sbin])
+if test x$BASH = "xno"; then
AC_MSG_ERROR([bash is required])
fi
-AC_CHECK_PROGS(SED, sed)
-if test x$SED = "x"; then
+AC_PATH_PROGS(SED, sed, "no")
+if test x$SED = "xno"; then
AC_MSG_ERROR([sed is required])
+else
+ export SED
fi
-AC_CHECK_PROGS(AWK, awk)
-if test x$AWK = "x"; then
+AC_PATH_PROGS(AWK, awk, "no")
+if test x$AWK = "xno"; then
AC_MSG_ERROR([awk is required])
+else
+ export AWK
fi
+
+AC_PATH_PROGS(MD5SUM, md5sum, "no")
+if test x$MD5SUM = "xno"; then
+ AC_MSG_ERROR([md5sum is required])
+fi
+
AC_CHECK_PROG(ac_cv_have_rpm, rpm, "yes", "no")
if test "x$ac_cv_have_rpm" = "xyes"; then
rpm --define '_topdir /tmp' > /dev/null 2>&1