aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2009-12-25 04:09:29 +0100
committerintrigeri <intrigeri@boum.org>2009-12-25 04:09:29 +0100
commit4996d8deb7fcf366f5c012ae919b1245db3d7b6a (patch)
tree7d65ee07a9db0106a47054f4127c9425b47541cd /configure.in
parentf4ab3148f175f8ac415b01fea61d14a80f4de969 (diff)
downloadbackupninja-4996d8deb7fcf366f5c012ae919b1245db3d7b6a.tar.gz
backupninja-4996d8deb7fcf366f5c012ae919b1245db3d7b6a.tar.bz2
autotools: added the stat command to the automagically replaced ones
... hoping it will help supporting *BSD some day.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 26e95be..174399d 100644
--- a/configure.in
+++ b/configure.in
@@ -36,6 +36,13 @@ if test x$MKTEMPT = "xno"; then
AC_MSG_ERROR([mktemp is required])
fi
+AC_PATH_PROGS(STAT, stat, "no")
+if test x$STAT = "xno"; then
+ AC_MSG_ERROR([stat is required])
+else
+ export STAT
+fi
+
AC_CHECK_PROG(ac_cv_have_rpm, rpm, "yes", "no")
if test "x$ac_cv_have_rpm" = "xyes"; then
rpm --define '_topdir /tmp' > /dev/null 2>&1