aboutsummaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2009-02-19 12:23:29 -0500
committerMicah Anderson <micah@riseup.net>2009-02-19 12:23:29 -0500
commit539fd1471907422d81626260ea4f1e23e4d398a4 (patch)
treeefe32e02a285fe1d241e16c6701a95a8201d79e7 /autogen.sh
parent27a7859c42394a78c16b24f0d08ca28667bb1efa (diff)
downloadbackupninja-539fd1471907422d81626260ea4f1e23e4d398a4.tar.gz
backupninja-539fd1471907422d81626260ea4f1e23e4d398a4.tar.bz2
move the branches directories up to the root of the repository
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh22
1 files changed, 22 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 0000000..aae1061
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,22 @@
+#!/bin/bash
+
+if [ "x$EDITOR" = "x" ];
+then
+ EDITOR=vi
+fi
+
+if [ "x$1" = "x-f" ]
+then
+ autoscan
+ [ -f "configure.in" ] && cp "configure.in" "configure.in.old"
+ mv -f "configure.scan" "configure.in"
+ echo "## This is just AUTOSCAN draft of configure.in"
+ $EDITOR "configure.in"
+fi
+
+### použít jen když je třeba použít configure.h.in
+#autoheader
+
+aclocal \
+&& automake -a -c \
+&& autoconf