aboutsummaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2005-11-29 10:08:41 +0000
committerintrigeri <intrigeri@boum.org>2005-11-29 10:08:41 +0000
commit280fdac2bc2146a73282b47b2c7ce66c19a0d3f2 (patch)
tree85ec2a0f56214647bdb33165d4caf4352fce5158 /Makefile.in
parent41f3fddfe2734b78e26dd5ca4ae1f0bd5c344119 (diff)
downloadbackupninja-280fdac2bc2146a73282b47b2c7ce66c19a0d3f2.tar.gz
backupninja-280fdac2bc2146a73282b47b2c7ce66c19a0d3f2.tar.bz2
r3555@krups: intrigeri | 2005-11-15 13:59:57 +0100
Moved easydialog.sh to lib/ directory: more code is going to be shared, let's start here.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in26
1 files changed, 19 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index 366d466..a0eb9ab 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1,8 +1,8 @@
-# Makefile.in generated by automake 1.9.2 from Makefile.am.
+# Makefile.in generated by automake 1.9.5 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004 Free Software Foundation, Inc.
+# 2003, 2004, 2005 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -129,7 +129,7 @@ target_alias = @target_alias@
EXTRA_DIST = README COPYING AUTHORS INSTALL NEWS ChangeLog \
backupninja.spec backupninja.spec.in autogen.sh
-SUBDIRS = etc examples handlers man src
+SUBDIRS = etc examples handlers lib man src
all: all-recursive
.SUFFIXES:
@@ -177,7 +177,13 @@ uninstall-info-am:
# (which will cause the Makefiles to be regenerated when you run `make');
# (2) otherwise, pass the desired values on the `make' command line.
$(RECURSIVE_TARGETS):
- @set fnord $$MAKEFLAGS; amf=$$2; \
+ @failcom='exit 1'; \
+ for f in x $$MAKEFLAGS; do \
+ case $$f in \
+ *=* | --[!k]*);; \
+ *k*) failcom='fail=yes';; \
+ esac; \
+ done; \
dot_seen=no; \
target=`echo $@ | sed s/-recursive//`; \
list='$(SUBDIRS)'; for subdir in $$list; do \
@@ -189,7 +195,7 @@ $(RECURSIVE_TARGETS):
local_target="$$target"; \
fi; \
(cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ || eval $$failcom; \
done; \
if test "$$dot_seen" = "no"; then \
$(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
@@ -197,7 +203,13 @@ $(RECURSIVE_TARGETS):
mostlyclean-recursive clean-recursive distclean-recursive \
maintainer-clean-recursive:
- @set fnord $$MAKEFLAGS; amf=$$2; \
+ @failcom='exit 1'; \
+ for f in x $$MAKEFLAGS; do \
+ case $$f in \
+ *=* | --[!k]*);; \
+ *k*) failcom='fail=yes';; \
+ esac; \
+ done; \
dot_seen=no; \
case "$@" in \
distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
@@ -218,7 +230,7 @@ maintainer-clean-recursive:
local_target="$$target"; \
fi; \
(cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ || eval $$failcom; \
done && test -z "$$fail"
tags-recursive:
list='$(SUBDIRS)'; for subdir in $$list; do \