diff options
author | Micah Anderson <micah@riseup.net> | 2010-10-31 16:44:43 -0400 |
---|---|---|
committer | Micah Anderson <micah@riseup.net> | 2010-10-31 16:44:43 -0400 |
commit | 84c2202ca35b6d9e739abe25e5612b06718774ee (patch) | |
tree | 3e36db0f3264400887a2261508c362d2ee54527a | |
parent | b87d36489ba1f584e6cfe3fec54de49dc9d1a2a6 (diff) | |
parent | ab92883a63860b626bfc2faafd54a1544e1b8583 (diff) | |
download | backupninja-84c2202ca35b6d9e739abe25e5612b06718774ee.tar.gz backupninja-84c2202ca35b6d9e739abe25e5612b06718774ee.tar.bz2 |
Merge branch '0.9.8.1' into debian
-rw-r--r-- | AUTHORS | 1 | ||||
-rw-r--r-- | ChangeLog | 7 | ||||
-rw-r--r-- | configure.in | 2 | ||||
-rwxr-xr-x | handlers/sys.in | 7 | ||||
-rwxr-xr-x | src/backupninja.in | 2 |
5 files changed, 15 insertions, 4 deletions
@@ -35,3 +35,4 @@ stefan <s.freudenberg@jpberlin.de> -- dup support for Amazon S3 buckets maniacmartin <martin@maniacmartin.com> -- rdiff confusing error message fix Chris Nolan <chris@cenolan.com> -- maildir subdirectory expansion Dan Carley -- mysql bugfix +Jordi Mallach <jordi@debian.org> -- do not error when no jobs are configured @@ -1,3 +1,10 @@ +version 0.9.8.1 -- October 31, 2010 (boo!) + backupninja changes + . Do not error out when no job is configured. Thanks to Jordi Mallach + <jordi@debian.org> for the patch (Closes: #597684) + sys: + . Route around broken vgcfgbackup not able to handle multiple VG arguments + version 0.9.8 -- September 12, 2010 backupninja changes . Added GZIP_OPTS option, defaulting to --rsyncable, so that this diff --git a/configure.in b/configure.in index 59ccd10..dd128c1 100644 --- a/configure.in +++ b/configure.in @@ -3,7 +3,7 @@ # The maintainer mode is causing me grief with newest versions of autotools #AM_MAINTAINER_MODE -AC_INIT([backupninja],[0.9.8],[backupninja@lists.riseup.net]) +AC_INIT([backupninja],[0.9.8.1],[backupninja@lists.riseup.net]) AC_CONFIG_SRCDIR([src/backupninja.in]) AM_INIT_AUTOMAKE diff --git a/handlers/sys.in b/handlers/sys.in index a92663e..fcf3e31 100755 --- a/handlers/sys.in +++ b/handlers/sys.in @@ -649,8 +649,11 @@ function doLvmBackup () { debug "$VGS --options vg_name --noheadings | @SED@ 's/^[ ]*//' | @SED@ 's/[ ]*$//' | tr '\n' ' '" vgs=`$VGS --options vg_name --noheadings | @SED@ 's/^[ ]*//' | @SED@ 's/[ ]*$//' | tr '\n' ' '` debug "Let's try to backup LVM metadata for detected volume groups: $vgs" - debug "$VGCFGBACKUP --file \"${lvmdir}\"/\'%s\' $vgs" - output=`$VGCFGBACKUP --file "${lvmdir}"/'%s' $vgs` + for vg in $vgs + do + debug "$VGCFGBACKUP --file \"${lvmdir}\"/\'%s\' $vg" + output=`$VGCFGBACKUP --file "${lvmdir}"/'%s' $vg` + done exit_code=$? debug $output case $exit_code in diff --git a/src/backupninja.in b/src/backupninja.in index b397a14..789debd 100755 --- a/src/backupninja.in +++ b/src/backupninja.in @@ -519,7 +519,7 @@ else files=`find $configdirectory -follow -mindepth 1 -maxdepth 1 -type f ! -name '.*.swp' | sort -n` if [ -z "$files" ]; then - fatal "No backup actions configured in '$configdirectory', run ninjahelper!" + info "No backup actions configured in '$configdirectory', run ninjahelper!" fi fi |